PHP5.4からは動かない・・・

かなり大昔にXoops 2.0.14というバージョンでサイトを作成したのです。当時、XoopsはUTF-8とかじゃなくEUCオンリーで、さらに、英語版、中文(中国語版)を作成するということで大変な目にあったことがあります。

まあでも、今でも、元気に動いてはいるのですが、Xoops 2.0.14というバージョンだけ気になってはいたのです。せめて2.0系最終バージョンの2.0.18とかにしておけば・・・

ま、それはそれとして、そのサイトは一応公的な要素の大きいサイトでしたが、今度そのサーバーをリプレースするということになり、さらに、PHPを4.4.9から5.5に飛び級しますというのですw

一応、その作業には微々たるものですがお金がでるということで高い高いといいつつ見積を出し了承されましたが・・・

で、php5.5・・・php4.4とはやはりいろいろ違いますw。一応テスト環境を作ってくれたので、そこで試したところ、いやー見事にエラーの嵐で動きません。
具体的なエラーとしては、

Strict Standards: Non-static method XoopsErrorHandler?::getInstance() should not be called statically in [xxxx]/xoops/class/errorhandler.php on line 202

とか

Strict Standards: Non-static method MyTextSanitizer::getInstance() should not be called statically, assuming $this from incompatible context in /kernel/object.php on line 288

とか、、、これは、
function &getInstance()

とかなら

public static function &getInstance()

にしろ。という話しなのですが、、、

それじゃ、
function &getInstance()
を片っ端から
public static function &getInstance()
すればいいのでは?というとそんな簡単な問題でもなく。。。

他にもエラーてんこ盛りで、これはかなり面倒臭いぉっと!
エラーが無くならないぞ!っと

念のため新規にXCL2.2.1という最新版をインストールしてみたらそんなに酷いエラーはでないですね。PHP5.5でも、、、なので、じゃあ、2.0.14から2.2.1までバージョンアップすればいいのか?と思ったんですが、、、

これがまたしこたま大変そうです。とりあえず、こことか参考にアップデートしてみたのですがエラー出まくりでアップデート作業もままならない。

あーどうする?、1ヶ月くらい時間あるなら別のCMSにでも載せ替えようかとも思ったのですが、来週いっぱいなんです・・・うううう 時間なさ過ぎる。

今は身の振り方をどうしようかと考え中です。日本語だけならなんとかなりそうだけど、英語、中国語もだもんなー、、、

php5.3にしてくれるなら、それが一番いいんですがねー

うーん

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください